No spark on centre cylinder

Any triple related issues, topics or stories then POST THEM HERE.......

No spark on centre cylinder

Postby IanT » Sun Dec 01, 2019 5:54 pm

Hi Guys,

Got a H2 750 1972, but got no spark on the centre pot. Checked plugs, checked coils - coils are new. Checked CDI unit (which is a 2nd hand unit that was fully working some 4-5 months ago) and think it's not working on the centre cylinder CDI unit now. Does anyone know anyone that re-furbishes or tests CDI units in the UK?

Many thanks in advance for any replies
IanT
 
Posts: 4
Joined: Tue Jul 03, 2018 7:09 am
Location: Watford

Re: No spark on centre cylinder

Postby Kawaclive » Sun Dec 01, 2019 10:58 pm

Rex Speed Shop near Robertsbridge in Sussex repair them 01580 880768.
Get it done in the winter, they have a waiting list!
Kawaclive
Expert
 
Posts: 507
Joined: Mon Oct 01, 2007 10:26 pm
Location: Surrey

Re: No spark on centre cylinder

Postby Collyolly » Mon Dec 02, 2019 8:46 am

Before you go to the trouble of sending your unit off for testing/repair have you done any simple electrical tests on your bike ?
I had a similar problem on my H2, I have a new Rex Speed shop CDI unit and thought it had failed after just the initial start up as I lost the spark on my left cylinder, I swapped around coils and the problem did not move so I assumed it was a failed new CDI.
Thinking about it now I should have swapped the feeds to and from the CDI to see if the problem moved but I was probably in panic/ hacked off mode !
I contacted Rex's to ask their opinion to be told they would be very surprised if it was their unit and had I done the standard electrical tests, so I got out my manual and multi-meter and found that I did not have the correct ohm reading from the left cylinder pickup. It transpired that the earth connection from the pickup to the backing plate was loose so no continuity.
Tightened up the screw, ohms reading 190, bike started.
Not saying this is your electrical fault but you have 40 year old bullet connectors that are all potentially dodgy.
Another example, my newly installed L.E.D. indicators worked fine on initial test but a couple of plays later they would not flash, I traced it to a badly corroded wire to pushfit terminal to the flasher unit, so an old dodgy connection just waiting to fail.
Good luck
Collyolly
Expert
 
Posts: 158
Joined: Fri Aug 17, 2018 7:52 pm
Location: Kent

Re: No spark on centre cylinder

Postby BIG H » Mon Dec 02, 2019 10:32 am

If you find you need to replace an ignition box let me know as i have some spare & a test rig to check them.
Check ALL wire connections as stated above.
My H2 went on to 2 cylinders, the problem was just a bad earth.
BIG H
Expert
 
Posts: 886
Joined: Thu May 04, 2006 11:52 am
Location: SITTINGBOURNE,KENT.


Return to All Things 'Triple' Related.

Who is online

Users browsing this forum: No registered users and 4 guests

cron